Syncro SVN Client

There are some resources being obstructed - error?

Having trouble installing Syncro SVN Client? Got a bug to report? Post it all here.

There are some resources being obstructed - error?

Postby onedayitwillmake » Sun Mar 28, 2010 10:07 pm

I get this error when trying to update my repository after upgrading to version 5.1

"There are some resourced being obstructed. Please repair them first."
-
I tried doing a clean up, but the error remains.


Any help would be appreciated :)
onedayitwillmake
 
Posts: 3
Joined: Sun Mar 28, 2010 10:02 pm

Re: There are some resources being obstructed - error?

Postby Florin » Mon Mar 29, 2010 8:47 am

Hello,

The error message you see is displayed as a result of the support added in Syncro SVN Client 5.1 for correct handling of the obstructed resources. You should check your working copy to see which resources are marked with a red square having an 'O' over it. They are in the obstructed state and the update is not allowed to run because it may fail and leave the working copy into a non-normal state (other operations also will not run over obstructed resources). A resource is in the obstructed state because SVN found another type of resource instead of the one it knew it must be and this state is achieved as a result of one of the following 4 situations:
1. you have deleted the working copy administrative folder ('.svn') from a directory under version control, leaving it as unversioned
2. you have deleted a folder and created a new file having the same name instead (without any extension)
3. you have deleted a file and created a new folder having the same name instead (including the file extension)
4. you have a symbolic link in your working copy and the symbolic link support is not enabled (valid only for Mac OS/Linux)

You should try to identify the obstructed resources and correct them before trying to perform another operation that will act on those resources. If you modified the resources as one of 1-3 situations and those modifications are important then you should copy them somewhere safe and after use the method described below to correct the working copy.

For the obstructed resources you can use the Delete option (Edit -> Delete) from the contextual menu to delete them and leave the original resources as missing. After, you can do an Update or Revert to bring them to the HEAD or BASE revision (take notice that it may happen that Revert or Update not to work in some situations, depending on what operations you previously did to obtain the obstructed state or if they were newly added to the working copy). After, the resources should be normal.
If you wish to replace those resources with the ones you saved then you should delete them from Syncro SVN Client, commit and finally copy back the resources you moved/saved previously. They will appear as unversioned and you can add them to be versioned. This is the correct form to replace some resources with another ones.

In case of point 4, none of the options above will work. A symbolic link will be always reported as obstructed if the symbolic link support is not enabled, so you should go into the Options dialog and in the SVN option pane enable the symbolic link support. Then restart and do an Override and Update over the obstructed resources to replace them with the correct resources.

All the obstructed resources are presented in the Incoming-Outgoing and Conflict Modes of the Synchronize View, so you can identify them quickly by the status.

Best regards,
Florin Avram
---------------
Syncro SVN Client
http://www.syncrosvnclient.com
Florin
 
Posts: 133
Joined: Mon Aug 10, 2009 4:02 pm

Re: There are some resources being obstructed - error?

Postby onedayitwillmake » Mon Mar 29, 2010 4:15 pm

The problem is, none of the directories in the tree show the red colored O icon (which i have seen in previous versions if i deleted the folder or other cases, so im familiar with it). In this case, the directories (in the entire tree downward) appear completely normal.
onedayitwillmake
 
Posts: 3
Joined: Sun Mar 28, 2010 10:02 pm

Re: There are some resources being obstructed - error?

Postby Florin » Mon Mar 29, 2010 4:40 pm

Hello,

I think you are doing a mistake. In the previous versions of Syncro SVN Client there was no icon for obstructed resources so I don't understand exactly what you mean. If you delete a resource from an external application and then come back in Syncro SVN Client, that resource will be marked with a red square icon having an '!' sign on it (incomplete). The resources being obstructed are marked with a red square with an 'O' sign on it in the working copy view and with the red double-headed-arrow in the Synchronize view.

The parent directories of an obstructed resource are not marked with anything for now (this is a known bug and it will be fixed soon) in the Working Copy view, but they may be marked with the modified icon (blue square with an '*' sign) if other child inside them is modified. In Synchronize view the parents of the obstructed resources are marked with the read double-headed-arrow.

If you wish, you can write to us on our support e-mail address (support@syncrosvnclient.com) and we may discus this more and you can even send us some screen-shots for proper identification of your problem.

Best regards,
Florin Avram
---------------
Syncro SVN Client
http://www.syncrosvnclient.com
Florin
 
Posts: 133
Joined: Mon Aug 10, 2009 4:02 pm


Return to Common Problems

Who is online

Users browsing this forum: No registered users and 1 guest


© 2002-2013 SyncRO Soft Ltd. All rights reserved. | Sitemap | Terms of Use | Privacy Policy | This website was created & generated with <oXygen/>® XML Editor