Special Characters Are Replaced With a Square in Editor

My file was created with other application and it contains special characters like é, ©, ®, etc. Why does Syncro SVN Client display a square for these characters when I open the file in Syncro SVN Client ?

You must set a font able to render the special characters in the Font preferences. If it is a text file you must set also the encoding used for non XML files. If you want to set a font which is installed on your computer but that font is not accessible in the Font preferences that means the Java virtual machine is not able to load the system fonts, probably because it is not a True Type font. It is a problem of the Java virtual machine and a possible solution is to copy the font file in the [JVM-home-folder]/lib/fonts folder. [JVM-home-folder] is the value of the property java.home which is available in the System properties tab of the About dialog that is opened from menu Help > About .