Syncro SVN Client

New history graph bug

Having trouble installing Syncro SVN Client? Got a bug to report? Post it all here.

New history graph bug

Postby mheeren » Wed Jun 06, 2007 4:54 pm

I just got v2.4 and installed it this morning. I went to try out the history graph function and got this:

Code: Select all
[ AWT-EventQueue-0 ]  -  java.lang.ArrayIndexOutOfBoundsException: 0
java.lang.ArrayIndexOutOfBoundsException: 0
   at ro.sync.svn.I.F.<init>(Unknown Source)
   at ro.sync.svn.I.B.A(Unknown Source)
   at ro.sync.svn.I.E.A(Unknown Source)
   at ro.sync.svn.C.F$2.run(Unknown Source)
   at ro.sync.ui.K$1.run(Unknown Source)
   at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
   at java.awt.EventQueue.dispatchEvent(EventQueue.java:461)
   at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:269)
   at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
   at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:184)
   at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:176)
   at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)


I am using MacOS 10.4.8 (Intel)
mheeren
 
Posts: 9
Joined: Thu May 03, 2007 3:38 pm

Postby sorin » Thu Jun 07, 2007 10:20 am

Hello,

How many revisions does the resource have? Please run the action Show History on the same resource that you try to display in the history graph.

Also you can try to display the history graph of the same resource with the new build of Syncro SVN Client 2.4 which guards the situation of zero revisions reported by the SVN server when the ArrayIndexOutOfBoundsException is obtained.


Regards,
Sorin
sorin
 
Posts: 171
Joined: Tue Feb 13, 2007 3:45 pm

Postby mheeren » Thu Jun 07, 2007 5:56 pm

I have tried the new build.

Now the error does not come up, only a blank window for the History Graph.

The working copies I am working with typically have 40-200 revisions. When I run "Show History" on the same resource, I successfully get the correct history for the resource.

I have tried the using the graph on the entire working copy, a folder within the copy and on an individual file - all with the same results.

If it makes any difference, most of these repositories are SVN v1.3.
mheeren
 
Posts: 9
Joined: Thu May 03, 2007 3:38 pm

Postby mheeren » Thu Jun 07, 2007 5:58 pm

I just tried another repo I have that is SVN v1.4.3 - it has 1 revision and the history graph does work properly - so I assume this is a SVN v1.3 issue.

I am going to try a few other things to see if I can backup this find.
mheeren
 
Posts: 9
Joined: Thu May 03, 2007 3:38 pm

Postby mheeren » Thu Jun 07, 2007 6:28 pm

Well, I just created creating a new repo and doing a dump of the 1.3 one and loaded it into the v1.4.3 one.

I did a checkout and hit the history graph - still just a blank page.

hope that helps :/
mheeren
 
Posts: 9
Joined: Thu May 03, 2007 3:38 pm

Postby sorin » Fri Jun 08, 2007 3:25 pm

Some SVN servers including SVN 1.3 ones reply with only one entry when a client requests all the revisions of a resource using a --limit parameter with the maximum value. We adapted the request so that it is accepted also by these servers. Please try the new build of SVN Client 2.4.


Regards,
Sorin
sorin
 
Posts: 171
Joined: Tue Feb 13, 2007 3:45 pm

Postby mheeren » Fri Jun 08, 2007 4:55 pm

First, let me say, I really appreciate the speedy responses :)

I have grabbed the new build and tried it out. I now get the first revision in the graph, nothing more. I am able to get full history by using "Show History". Here is what is in the console for each:

Show History:
Code: Select all
[09:29:45] - svn log --revision HEAD:1 --limit 50 --verbose RepoName
[09:29:47] - Operation successful


History Graph:
Code: Select all
[09:29:51] - svn info RepoName

[09:29:51] - svn log --revision HEAD:1 --verbose http://server.com/reponame
[09:29:55] - Operation successful


The server itself should be v1.4 - I just have some repositories created while on v1.3, I am not sure if that makes any difference.

I did try converting one of the old repos to a new v1. repo - and nothing really changed.

Once again, thanks for the speedy help!
mheeren
 
Posts: 9
Joined: Thu May 03, 2007 3:38 pm

Postby sorin » Mon Jun 11, 2007 8:47 am

Hello,

Is your build number 2007060818 in the Help -> About dialog? This is the build that should fix the incomplete history graph problem.


Regards,
Sorin
sorin
 
Posts: 171
Joined: Tue Feb 13, 2007 3:45 pm

Postby mheeren » Tue Jun 12, 2007 9:48 pm

I was using build 2007060818

I just upgraded, now they are not empty. If I show a graph on a folder, I see the revisions for that folder if I click the "Show/hide indirect modifications" icon. I never see files inside the folder though, only branches, is that the correct behavior? If so, then this is all fixed.
mheeren
 
Posts: 9
Joined: Thu May 03, 2007 3:38 pm

Postby mheeren » Tue Jun 12, 2007 9:49 pm

Sorry, i meant to say i was using 2007060813
mheeren
 
Posts: 9
Joined: Thu May 03, 2007 3:38 pm

Postby sorin » Wed Jun 13, 2007 9:24 am

Hello,

Yes, that is the correct behavior. The graph for a folder contains only revisions of the folder, not of any file inside the folder. Indirect modifications are revision numbers changed on the folder resource due to new revisions of file resources contained in that folder.


Regards,
Sorin
sorin
 
Posts: 171
Joined: Tue Feb 13, 2007 3:45 pm


Return to Common Problems

Who is online

Users browsing this forum: No registered users and 2 guests


© 2002-2013 SyncRO Soft Ltd. All rights reserved. | Sitemap | Terms of Use | Privacy Policy | This website was created & generated with <oXygen/>® XML Editor